はじめに

CD Manipulator

はじめに

CD ManipulatorはCDイメージ作成・ライティングソフトです。 CDのコピーからオリジナルCDの作成まで、幅広くご利用いただけます。 CD Manipulatorは、フリーな環境でCDライティングすることを目標に作成されており、Windows 98/98SE/Me/2000/XPの各OSで動作します。 （USBやIEEE1394のドライブはWindows 2000/XPのみの対応となります）

CD Manipulatorの特徴
  • プリギャップの解析やRAW+96に対応した、強力なコピー機能。
  • データトラックにも対応し、簡単に操作できるマスタリング機能。
  • 正確なギャップ位置やトラック位置を取得する、サブチャンネル解析機能。
  • 隠しトラックも再現できる、プリギャップ解析機能。
  • フリーウェアなので、無料で使えます！

注意事項

コピープロテクト付きCDのコピーは、環境さえ整えばある程度可能ですが、 そのやり方などの質問は一切受け付けません。
使い方も含めて、完全に自己責任でお願いします。

対応イメージ
  • iso
  • cue+bin/img（CD Manipulatorの作成したイメージのみ）
  • ccd+img+sub
  • cdm+img+sub+pre
Copyright(c) Y.Kanechika


 CD Manipulatorについて
著作権と免責事項
  • CD Manipulatorの著作権はY.Kanechikaが有します。
  • CD Manipulatorにより生じた、いかなる障害・損害においてもY.Kanechikaは責任を負いません。

改変について
  • プログラム及びドキュメントの改変を行う場合は、著作権表示部を書き換えてはいけません。
  • 改編したプログラムやドキュメントを配布する際は、改変者と改変部位を明記したドキュメントを必ず添付すること。

再配布について
  • オリジナルの圧縮形式のままで無償配布するのであれば、再配布に制限は設けません。
  • 改変されたプログラムの配布には【改変について】に同意する必要があります。
  • いかなる場合であれ、有償で配布する際は著作権者の許可が必要です。

Special Thanks
次の方々は、CD Manipulatorの黎明期に尽力いただいたので、この場を借りてお礼を申し上げます。
  • ＹＳＳさん
  • ななしのさん
  • Kaiser Roseさん
  • みゅうさん

連絡先
Y.Kanechika
Web: http://www.storeroom.info/cdm/
E-Mail: webmaster@storeroom.info


 動作環境
コンピュータ
CD Manipulatorは、要件を満たしたコンピュータで動作します。
  • PC/AT互換機
  • メモリ 64MB以上
  • CPU MMX Pentium 200MHz以上
  • HDD 空き容量1GByte以上(イメージ保存用)
  • VGA 800x600以上 / 256色以上

オペレーティングシステム(OS)
CD Manipulatorは、次のいずれかのOS上で動作します。
  • Windows 98
  • Windows 98 Second Edition
  • Windows Millennium Edition
  • Windows 2000 Professional/Server
  • Windows XP Home/Professional

CD-R/RWドライブ
CD Manipulatorを使用するには、次の条件を満たしたCD-R/RWドライブが必要です。
  • SCSI/IDEで接続されたドライブ(Windows 98/98SE/Me)
  • SCSI/IDE/IEEE1394/USBで接続されたドライブ(Windows 2000/XP)
  • MMC命令に対応したドライブ(動作ドライブリストを参照)


 動作ドライブリスト
※このリストは、あくまでも目安です。リストで○でも、動作しない場合もあります。
○…動作した報告あり
○？…動作すると思われる
△…動作に制限あり
 ×？…動作しないと思われる
×…動作しなかった報告あり
×…コースターができあがる
？…報告無し

CD-R/RW
メーカー | ドライブ名 | 読み | ギャップ | 焼き RAW+16 | 焼き RAW+96 | 焼き SAO | 備考
Acer | CRW-1610A | ○ | ？ | ○ | ○ | ○ | -
Acer | CRW-2010A | ○ | × | ○ | ○ | ○ | -
AOpen | CRW2440 | ○ | ？ | × | ○ | ○ | -
AOpen | CRW4048 | ○ | ？ | ○ | ○ | ○ | -
ARTEC | WRA-WA48 | ○ | ？ | × | ○ | ○ | -
Asus | CRW-3212A | ○ | ？ | ？ | ○ | ？ | -
Asus | CRW-5224A | ○ | -148 | ○ | ○ | ○ | -
メーカー | ドライブ名 | 読み | ギャップ | 焼き RAW+16 | 焼き RAW+96 | 焼き SAO | 備考
BenQ | IDE1612CO | ○ | -100 | ○ | ？ | ○ | -
BenQ | 3210A | ○ | ？ | ○ | ○ | ○ | -
BTC | BCE1610IM | ○ | ？ | ○？ | ○？ | ○？ | -
BTC | CRW4816P | ○ | -144 | ○ | ○ | ○ | -
メーカー | ドライブ名 | 読み | ギャップ | 焼き RAW+16 | 焼き RAW+96 | 焼き SAO | 備考
Cyber Drive | CW018D | ○ | ？ | ○ | ○ | × | -
メーカー | ドライブ名 | 読み | ギャップ | 焼き RAW+16 | 焼き RAW+96 | 焼き SAO | 備考
IO-DATA | CRWD-iU12J | ○ | -145 | × | ○ | △ | -
メーカー | ドライブ名 | 読み | ギャップ | 焼き RAW+16 | 焼き RAW+96 | 焼き SAO | 備考
JVC(Victor) | XR-W4424 | ○ | ？ | ○ | ○ | ○ | -
メーカー | ドライブ名 | 読み | ギャップ | 焼き RAW+16 | 焼き RAW+96 | 焼き SAO | 備考
LG(日立) | CED-8120B | ○ | ？ | ○ | ○ | ○ | -
LG(日立) | GMA-4020B | ○ | -141 | ○ | ○ | ○ | -
LG(日立) | GCE-8160B | ○ | -144 | ○ | ○ | ○ | -
Lite-On | LTR-12101B | ○ | × | × | ○ | ○ | -
Lite-On | LTR-16102B | ○ | -141 | ？ | ○ | ？ | -
Lite-On | LTR-24102B | ○ | -144 | ○？ | ○ | ○ | -
Lite-On | LTR-32123S | ○ | -145 | ○？ | ○ | ○ | -
Lite-On | LTR-40125S | ○ | -145 | ○ | ○ | ○ | -
Lite-On | LTR-40125W | ○ | -145 | ○ | ○ | ○ | -
Lite-On | LTR-48125W | ○ | -145 | ○ | ○ | ○ | -
Lite-On | LTR-48246S | ○ | -145 | ○ | ○ | ○ | -
Lite-On | LTR-52246S | ○ | -143 | ○ | ○ | ○ | -
メーカー | ドライブ名 | 読み | ギャップ | 焼き RAW+16 | 焼き RAW+96 | 焼き SAO | 備考
MATSHITA | UJDA310 | ○ | × | × | × | ○ | -
MATSHITA | UJDA710 | ○ | ？ | ○ | ○ | ○ | -
MATSHITA | UJDA720 | ○ | × | × | ○ | ○ | -
MATSHITA | UJDA730 | ○ | ？ | × | ○ | ○ | -
MATSHITA | UJDA740 | ○ | × | × | ○ | ○ | -
MATSHITA | CDRRW01 | ○ | ？ | × | × | ○ | -
MATSHITA | CW-8572 | ○ | ？ | ○ | ○ | ○ | -
MITSUMI | CR-4805TE | ○ | ？ | ○ | ○ | ○ | -
メーカー | ドライブ名 | 読み | ギャップ | 焼き RAW+16 | 焼き RAW+96 | 焼き SAO | 備考
NEC | NR-9200A | ○ | ？ | × | ○？ | ？ | -
NEC | NR-7900A | ○ | ？ | × | ○ | ○ | -
NEC | NR-7800B | ○ | ？ | × | ○ | × | -
NEC | NR-7800A | ○ | × | × | ○ | ○ | -
メーカー | ドライブ名 | 読み | ギャップ | 焼き RAW+16 | 焼き RAW+96 | 焼き SAO | 備考
Philips | CCD4401 | ○ | × | ○ | × | × | -
Philips | CDRW228 | ○ | ？ | ○ | ○ | ○ | -
Philips | CDRW321240 | ○ | ？ | ○ | ○ | ○ | -
Plextor | PX-320A | ○ | -140 | ○ | ○ | ○ | -
Plextor | PX-W4824A | ○ | -140 | ○ | ○ | ○ | -
Plextor | PX-W4012TU | ○ | -140 | ○ | ○ | ○ | -
Plextor | PX-W4012TA | ○ | -140 | ○ | ○ | ○ | -
Plextor | PX-W2410A | ○ | -140 | ○ | ○ | ○ | -
Plextor | PX-W1610TA | ○ | -140 | ○ | ○ | ○ | -
Plextor | PX-W1210TSi | ○ | -140 | ○ | ○ | ○ | -
Plextor | PX-W1210TA | ○ | -140 | ○ | ○ | ○ | -
Plextor | PX-W124TS | ○ | -140 | ○ | ○ | ○ | -
Plextor | PX-W8432TA | ○ | -140 | ？ | ○ | ○ | -
Plextor | PX-W8220Ti | ○ | -140 | ○ | ○ | ○ | -
Plextor | PX-R820Ti 新 | ○ | -140 | × | ○ | ○ | -
Plextor | PX-R820Ti 旧 | ○ | -140 | × | △(1xのみ) | ○？ | -
Plextor | PX-W4220T | ○ | -140 | ○ | ○ | ○ | -
Plextor | PX-R412C | ○ | ？ | ○ | ○ | ○ | -
メーカー | ドライブ名 | 読み | ギャップ | 焼き RAW+16 | 焼き RAW+96 | 焼き SAO | 備考
RICOH | MP5125A | ○ | -145 | ？ | ○ | ？ | -
RICOH | MP9060 | ○ | ？ | × | ○ | ○ | -
RICOH | MP6201S | ？ | ？ | × | ？ | ？ | -
RICOH | MP6200S | △ | ？ | × | × | × | -
RICOH | MP7043A | ○ | -141 | × | ○ | ○ | -
RICOH | MP7125 | ○ | ？ | × | ○ | ○ | -
RICOH | MP7200 | ○ | 149 | × | ○ | ○ | -
RICOH | MP9120A | ○ | -145 | × | ○ | △ | -
メーカー | ドライブ名 | 読み | ギャップ | 焼き RAW+16 | 焼き RAW+96 | 焼き SAO | 備考
SANYO | CDR-BP4 | ○ | ？ | × | ？ | ○ | -
SANYO | CRD-BP1700P | ○ | × | ？ | ○？ | ？ | -
SONY | CRX195E | ○ | ？ | × | ○？ | ○？ | -
SONY | CRX175E | ○ | × | × | △ | △ | 相性悪し
SONY | CRX160E | ○ | -148 | × | △ | △ | 相性悪し
SONY | CRX140E | ○ | -144 | × | △ | △ | 相性悪し
SONY | DRU-500A | ○ | × | × | ○ | ○ | -
メーカー | ドライブ名 | 読み | ギャップ | 焼き RAW+16 | 焼き RAW+96 | 焼き SAO | 備考
TEAC | CD-R55S | ×？ | × | × | × | × | -
TEAC | CD-R56S | ○ | × | × | × | ○ | -
TEAC | CD-W28E | ○ | ？ | × | × | ○ | -
TEAC | CD-W54E | ○ | -140 | ○ | ○ | ○ | -
TEAC | CD-W58E | ○ | -145 | ○ | ○ | ○ | -
TEAC | CD-W512E | ○ | -145 | ○ | ○ | ○ | -
TEAC | CD-W516E | ○ | -145 | ○ | ○ | ○ | -
TEAC | CD-W524E | ○ | ？ | ○ | ○ | ○ | -
TEAC | CD-W540E | ○ | -140 | × | ○ | ○ | -
TEAC | CD-W548E | ○ | -70 | ○ | ○ | ○ | -
Toshiba | SD-R1202 | ○ | -75 | × | ○ | ○ | -
Toshiba | SD-R2202 | ○ | -75 | × | ○ | ○ | -
Toshiba | SD-R2312 | ○ | ？ | × | ○ | ○ | -
Toshiba | SD-R5002 | ○ | -75 | × | ○ | ○ | -
メーカー | ドライブ名 | 読み | ギャップ | 焼き RAW+16 | 焼き RAW+96 | 焼き SAO | 備考
YAMAHA | CRW2200E | ○ | ？ | × | ○ | ○ | -
YAMAHA | CRW2200E | ○ | × | × | ○ | ○ | -
YAMAHA | CRW3200E | ○ | -137 | × | ○ | ○ | -
YAMAHA | CRW-F1 | ○ | -135 | × | ○ | × | -
CD-ROM
メーカー | ドライブ名 | 読み | ギャップ | 焼き RAW+16 | 焼き RAW+96 | 焼き SAO | 備考
LG(日立) | GD-7000 | ○ | -149 | × | × | × | -
LG(日立) | GD-7500 | ○ | -145 | × | × | × | -
LG(日立) | GDR-8160B | ○ | -145 | × | × | × | -
Lite-On | LTD-163D | ○ | -145 | × | × | × | -
MATSHITA | CR-504-J | × | × | × | × | × | -
NEC | NR-700A | ○ | × | × | × | × | -
Panasonic | LF-D321 | ○ | -75 | × | × | × | -
Pioneer | DVD-114 | ○ | ？ | × | × | × | -
Pioneer | DVD-500M | ○ | -100 | × | × | × | -
Pioneer | DR-U10X | × | × | × | × | × | -
Plextor | PX-40T | ○ | × | × | × | × | -
TEAC | CD-532S | ○ | × | × | × | × | -
TOSHIBA | SD-M1612 | ○ | × | × | × | × | -
TOSHIBA | SD-M1502 | ○ | × | × | × | × | -
TOSHIBA | SD-M1401 | ○ | × | × | × | × | -
TOSHIBA | XM-4101TA | × | × | × | × | × | -
DAEMON | Daemon Tools | ○ | × | × | × | × | -
- | - | ？ | ？ | ？ | ？ | ？ | -

コメント
  • コマンドについて、RAW+96かRAW+16が対応していれば問題ないでしょう。
  • コースターとは失敗して使い物にならないＣＤの事です。
  • PREGAPの読み込みについては、あくまでも目安です。多少違う値になる事もあります。


Revision History

 更新履歴
更新履歴
○Version 2.69
・データトラックのコンペア機能を搭載。
・その他細かい修正。
○Version 2.68
・読み込みダイアログのデザインを変更。
・作業の成功／失敗時に音を鳴らすよう変更。
・その他細かい修正。
○Version 2.67
・マルチセッションの書き込みを少し改良。
・設定ダイアログをタブ形式にした。
・その他細かい修正。
○Version 2.66
・マルチセッションイメージ作成がうまくいかないバグを修正。
・細かい修正。
○Version 2.65
・RAW+16でもマルチセッションモードが扱えるようにした。
・不正なサブチャンネルでも、ある程度正常に書き込めるようにした。
・その他、細かい修正。
○Version 2.64
・イメージ作成時にサブチャンネル解析されない事のあるバグを修正。
・ダイアログのデザインを一部変更。
・CHM形式のヘルプを採用。
○Version 2.63.1
・一時ファイルの削除に関するバグの修正。
○Version 2.63
・マスタリングエンジンにプロテクト作成機能を追加。
・ファイルが多いとうまくマスタリング出来ないバグを改善。
・マスタリング時のファイルソート速度を向上。
○Version 2.62
・エラーの高速スキップを改良。（エラー時のリトライ回数を０にした）
○Version 2.61
・メモリリークしそうな部分を修正。
・ASPI/SPTI関連の不具合を修正。
・CDDA読み込みコマンドの自動取得アルゴリズムを微妙に改良。
○Version 2.60
・うまくマスタリングできない事のあるバグを修正。
・マルチセッション読み込みの改良。
・SPTIに対応(Windows 2000/XPのみ)
・そのほか細かい修正。
○Version 2.59
・サイズ０のファイルを入れるとうまくマスタリングできないバグを修正。
・プロセスの優先度を設定できるようにした。
・ドライブの選択をコンボボックスへ統一した。
・そのほか細かい修正。
○Version 2.58
・マルチセッション読み込み時に不正終了することがあるバグを修正。
○Version 2.57
・マスタリングUIの挙動をいくつか変更。
・ISOファイルをデータトラックとしてマスタリングできるようにした。
○Version 2.56
・マスタリングに関するバグをいくつか修正。
・マスタリングUIの内部構造を大幅変更。
・その他細かい修正。
○Version 2.55
・マスタリング時の年表記が変になるバグを修正。
・ログへWindowsとASPIのバージョン情報を表示するように改良。
・その他細かい修正。
○Version 2.54
・マスタリング時の時刻関係を修正。
・マルチセッションモードで音楽ＣＤの書き込みが変になる事があるバグを修正。
・マルチセッションモードの読み書きでCD-TEXTへ対応した。
・マルチセッションモードの読み込み部分を少し改良。
○Version 2.53
・サブチャンネル解析、マルチセッションモード、プリギャップ解析のコマンド体系を見直した。
・マスタリングでの、フォルダの作成時間をJPN-9にした。
・その他細かい修正。
○Version 2.52
・マルチセッションモードでエラーメッセ時が出ないバグを修正。
・マスタリングに関するバグフィックス。
・サブチャンネル解析を少々改造。
・RAW+16でもマルチセッションモードが使えていたバグを修正。
・その他細かい修正。
○Version 2.51
・ログ関係を色々変更
・マルチセッションモードのバーストエラー無視が出来ないバグを修正。
・マスタリング時に、ディスクの容量を表示するようにした。
・その他細かい修正
○Version 2.50
・マルチセッションモードでうまく書き込めないバグを修正。
・プリギャップの解析機能を追加（マルチセッションモード専用）。
・.cueファイル名に関するバグをさらに修正。
○Version 2.49
・.cueファイル中のファイル名が変になるバグを修正。
・マルチセッションモードでイメージを作成しなかったら強制終了するバグを修正。
・初回起動時に言語を訪ねるように変更。
・マスタリング時に、既存フォルダの内容を一括登録できる機能を追加。
・マルチセッション読み込みを、サブチャンネル解析と同時に行うよう改良。
・その他細かい修正
○Version 2.48
・イメージをマスタリングした時のポストギャップ問題を解決。
・マスタリング時に、ファイル名を切りつめる際は警告を表示するようにした。
・マスタリング時に、元となるファイルのファイル名も表示するようにした。
○Version 2.47
・マルチセッションイメージの書き込みに対応。(.cdmファイルを利用)
・サブチャンネルの書き込みに対応。(.cdmファイルを利用)
・メインウィンドウに最小化ボタンを付けた。
・マルチセッションイメージは.cdm形式（独自形式）で保存するように変更。
・その他細かい修正。
○Version 2.46
・マスタリングのフォルダに関するバグを修正。
・再起動しないで言語を切り替えられるように変更。
・再起動しないでASPIを切り替えられるように変更。
○Version 2.45
・メインウィンドウを少し小さくした（スキンは今までのバージョンと互換）。
・再起動せずにスキン変更ができるようにした。
・マスタリング時に沢山フォルダがあるとイメージが壊れるバグを修正。
○Version 2.44
・マスタリング時に、ファイル名（フォルダ名）が重複してしまうバグを修正。
・CCDの互換性を向上。
・その他細かい修正
○Version 2.43
・マルチセッションのＣＤをサブチャンネル解析できないバグを修正。
・サブチャンネル解析で、ギャップの位置が微妙にずれる事のあるバグを修正。
・バーストエラーの高速スキップのバグを修正。
・マルチセッションモードで、ISRCを解析するようにした。
・マルチセッションモードで、MCNを解析するようにした。
・その他細かい修正
○Version 2.42
・マルチセッションＣＤの読み込みに対応（CCD形式で出力）
・サブチャンネルの読み込みに対応（CCD形式で出力）
・その他細かい修正
○Version 2.41
・サブチャンネル解析にバグがあったのを修正
・サブチャンネル解析を（若干）高速化
・トラック１のプリギャップ解析に対応
・サブチャンネル解析の速度を変更できるようにした
・その他細かい修正
○Version 2.40
・サブチャンネル解析のバグを修正
・TOCウィンドウからCue-Sheetを作成できるようにした
・その他細かい修正
○Version 2.39
・サブチャンネル解析の部位を刷新
・マスタリングダイアログの挙動を少し変更
・Windows9x系でボタンの説明が表示されないバグを解消（かなり力技）
・それぞれのウィンドウの位置を記憶するようにした
○Version 2.38
・スキンの変更機能を搭載
・ライティング終了時の処理をさらに変更
・その他細かい修正
○Version 2.37
・メインダイアログを大手術
・ライティング終了時の処理を少し変更した
・その他細かい修正
○Version 2.36
・多言語対応
・その他細かい修正
○Version 2.35
・ＳＡＯの焼きエンジンにバグがあったのを修正
○Version 2.34
・TOCの内容をファイルに保存できるようにした
・SAOモードのライティングエンジンを少し改良
・その他細かいバグを修正
○Version 2.33
・マスタリング時に、Ｆ２キーで名前の変更が出来るようにした
・ログの自動保存機能を追加
・ログとTOCのウィンドウの表示・非表示を保存できるようにした
・その他色々変更
○Version 2.32
・ASPIを変更できるようにした
・バーストエラーの読み込みＡＩを搭載した(Intelligent bad sector scanner)
○Version 2.31
・ドライブのライティング能力を調べる機能を追加
・MODE2イメージの書き込みに対応
・マスタリングの操作性を向上
・その他色々修正
○Version 2.30
・マスタリング（イメージ作成）エンジンの大幅改変
・マスタリング（イメージ作成）のＵＩを改良
○CD Manipulator Version 2.29
・名前をThe HermitからCD Manipulatorへ変更
・マスタリング機能にバグが発見されたので修正
○Version 2.28
・ライティングコマンドの自動検出を搭載した
・ミニ・アップデートなので、その他はほとんど変わってません
○Version 2.27
・ＣＤ複製機能を搭載。（イメージ作成とライティングを組み合わせた）
・ＣＤマスタリングを直接行えるようにした。（イメージファイルを作成する必要なし）
・インターフェイスを少し変更した
・その他細かい修正
○Version 2.26
・トラック毎の読み込みがうまくいかなかったバグを修正
・ライティングエンジンの改良（対応ドライブが増えたかも）
○Version 2.25
・ＳＡＯモードで第２トラック以降が変な構成になってしまうバグを修正
・一度に送るデータを制限するようにした（送信ブロックサイズの変更）
これにより、対応ドライブが増えるかも
・その他いろいろ細かい修正
○Version 2.24
・ライティングコマンド「RAW+96(Packed)」を追加
・ECCのチェックを行わないオプションを追加（ドライブの対応が必要）
・ＣＤへの各種命令について、より厳密に行うようにした（バグフィックス）
・ＵＩを変更した。（分かりやすくなったと思う）
・その他細かい修正
○Version 2.23
・ライティング機能を搭載
・CD-RWメディアの初期化機能を搭載
・その他細かい修正
○Version 2.13
・LBA→MSFやMSF→LBAの計算機を搭載
・その他、細かいバグを修正
○Version 2.12
・正常にマスタリング出来ない事があるバグを修正
・各種設定をHermit2.iniへ保存するようにした
・イメージの出力をcue+binにした（これによりCDRDAOで焼けるようになった）
○Version 2.11
・ＣＤイメージのマスタリング機能の致命的バグを修正
・ＣＤ読み込みコマンドの自動検知を標準でＯＮにした
○Version 2.10
・読み取りのバグをいくつか修正
・ＣＤイメージのマスタリング機能を追加
○Version 2.03
・サブチャンネル解析のアルゴリズムを改良した。
・サブチャンネル解析のアルゴリズムを選択式にした。（従来の方式は等倍追跡）
・CueSheet出力時のバグを直した。
・エラーの認識を厳密にした。
・その他細かい修正をした。
○Version 2.02
・オーディオトラックの読み取りコマンドを増やしてみた。
・読み取りコマンドの自動検知を入れてみた。
・サブチャンネル解析を導入。
・その他細かいバグを修正した。
○Version 2.01
・ファイル名入力に関するバグを色々と修正。
・オーディオトラックの読み取りコマンドを増やしてみた。
・CueSheet等で変なアドレスが出てくるバグを修正した。
・データトラックの最後２セクタが読み取れないことを予期できるようにした。
・オーディオの左右チャンネルを入れ替えられるようにした。
・読み取り時にエラーが発生しても最後まで読みつづけられるようにした。
・データトラックをトラック単位で読みとる場合のファイルを2352/blockにした。
注：データトラックの最後にある読み取り不可能なギャップはエラー無いようです。
○Version 2.00β
・トラック単位での読み取りをサポート。
・その他に、バグや細かい修正を行いました。
○Version 2.00α
・前のHermitがあまりにもバグバグしていたので、０から書き直しました。
・一応、ベータ版扱いでお願いします。
○The Hermit Version 1.00
・初版でした。
・普通のプログラムです。


 インストール
インストーラ（.exe形式）の場合
.zipファイルを解凍する環境の無い人は、こちらの方法でインストールしてください。

  1. cdm-jp.exe(又はcdm-eng.exe)をダウンロードする。
  2. ダウンロードしたcdm-jp.exe(又はcdm-eng.exe)を実行する。
  3. インストーラの指示通りに進む。

.zipの書庫形式の場合
ZIPファイルを扱う環境をお持ちの方は、こちらの方法でインストールしてください。
  1. cdm???.zipをダウンロードする。
  2. インストールするフォルダを作成する。
  3. お手持ちの解凍ツールで、cdm???.zipをインストールするフォルダへ解凍する。

Windows Me/XP等では、Windowsが標準で解凍機能を装備しています。その場合は、こちらの手順でどうぞ。
  1. cdm???.zipをダウンロードする。
  2. インストールするフォルダを作成する。
  3. cdm???.zipをダブルクリックすると、中身が見れます。
  4. cdm???.zipの中身を、インストールするフォルダへコピーする。


 アンインストール
インストーラを使ってインストールした場合
メニューからCD Manipulatorのアンインストールを選んでください。

.zip書庫形式からインストールした場合
インストールしたフォルダごと削除してください。

CD Manipulatorはレジストリを変更しません。また、システムファイルも変更しません。


 アップデート
直接アップデートする方法
  1. インストールと同じ手順で、古いCD Manipulatorのあるフォルダへインストールしてください。
  2. 上書き警告が出た場合は、構わず上書きしてください。

再インストールする方法
  1. アンインストールの手順に従って、古いCD Manipulatorをアンインストールしてください。
  2. インストールの手順に従って、新しいCD Manipulatorをインストールしてください。


 使い方

イメージ作成 | CDからイメージを作成します
トラックの読み込み | CDからトラック単位で読み込みます
イメージの書き込み | CDのイメージを書き込みます
CDのコピー | CDをコピーします
マスタリング | オリジナルCDを作成します
各種設定 | 各種設定を行います


 イメージ作成
イメージの作成方法
  1. メニューから「イメージ作成」を選んでください。
  2. 読み込むためのドライブを確認してください。
  3. イメージファイルを保存するファイル名を指定してください。「検索」ボタンで選ぶ事が出来ます。
  4. ＯＫボタンを押してください。

※警告について
ＣＤによっては「読みとり不可能なギャップの復旧」と警告が出る場合がありますが、これは仕様の範囲内です。
ギャップ部分が読めない事はたまにあるので、その時にこの警告が出ますが、データに影響はありません。

各種オプション

テストモード | ディスクのテスト読み込みを行います。 Cue Sheetもイメージファイルも作成されません。 標準ではＯＦＦにしてください。
音楽トラックの読み込み速度 | 音楽トラックの読み込み速度を変更できます。 通常は最高速度でも良いですが、傷が付いたCDを読み込む場合は速度を落としてください。 マルチセッションモードでは、音楽トラックもデータトラックも、こちらの速度で読み込みます。
データトラックの読み込み速度 | データトラックの読み込み速度を変更できます。 通常は最高速度でも良いですが、傷が付いたCDを読み込む場合は速度を落としてください。 マルチセッションモードでは、こちらの設定は無視されます。

高度な設定

プリギャップ解析 | ディスクのマイナス領域(-150～0)を読み込みます。 マルチセッションモード専用で、さらにドライブを選びます。
正しいTOCとギャップ情報の取得 | サブチャンネルを解析して、正確なトラックとギャップの位置を取得します。 ギャップ情報も取得したい場合はONにしてください。
読み込みエラーの無視 | エラーが発生しても、強制的に読み込みを続けます。 ディスクの読み込み中にエラーが発生して困る場合のみONにしてください。
エラーの高速スキップ | データトラックのEDCエラーチェックを行いません。 また、読み込みエラーが発生しても、再読込しませんので、エラーの検出が高速になります。 エラーが多発して困る場合のみONにしてください。
バーストエラーの高速スキップ | 連続してエラーが発生する場合に高速にエラーをスキップできます。 ただし、うまく読めるところもエラーとして認識する可能性もあるので注意してください。 連続して読み込みエラーが出てくる場合のみONにしてください。
CDDAチャンネルの入れ替え | 音楽トラックの読み込み時に左右のチャンネルを入れ替えます。 サウンドカードの出力が左右逆になる場合のみONにしてください。
CDDA読み込みコマンドの自動検知 | 音楽トラックの読み込みコマンドを自動的に検出します。 ドライブによって最適なコマンドが違いますが、通常はONで使用してください。

CDDAの読み込みコマンド
お勧め度 | MMC LBA/MMC MSF | MMCコマンドによるCDDA読み取りです。 LBAとMSFの違いはアドレス指定方式だけです。
☆☆ | READ(10) | MMCコマンドを使わない方式です。 MMC系のコマンドが使えない場合にこちらを指定してください。
☆☆☆☆ | READ D8 | Plextorドライブに最適化されたコマンドを使います。 一部のドライブでしか使えませんが、MMC系よりも良い感じです。
☆ | READ D4(10)/Read D4(12)/Read D5 | 一部のドライブで利用可能な命令です。
☆☆☆ | MMC LBA(RAW)/MMC MSF(RAW) | 基本的にはMMC LBA/MSFと同じですが、読み取りデータとしてRAW形式を指定します。
☆☆☆ | MMC READ CDDA LBA(RAW) MMC READ CDDA MSF(RAW) | 基本的にはMMC LBA/MSFと同じですが、音楽専用の命令です。


 トラックの読み込み
トラック単位での読み込み方法
  1. トラックリストから、読み込みたいトラックを選択してください。（複数選択可）
  2. メニューから「トラックの読み込み」を選択してください。
  3. ファイル名を指定してください。「検索」ボタンを押すと選ぶ事が出来ます。ファイル名を指定すると、トラックごとのファイル名がリストへ現れます。
  4. OKボタンを押してください。
CDが痛んでいるなどで正しくTOCが認識されていない場合には、あらかじめ正しいTOCとギャップ情報の取得を行っておいて下さい。
各種オプションについては、イメージ作成を参照してください。


 イメージの書き込み
イメージの書き込み方法
  1. メニューから「書き込み」を選んでください。
  2. 書き込むためのドライブを確認してください。
  3. 書き込むイメージファイル名を指定してください。「検索」ボタンで選ぶ事が出来ます。
  4. OKボタンを押してください。
※マルチセッションイメージ(.cdm .ccd)を指定すると、自動的にマルチセッションモードで書き込みます。

各種オプション

テストモード | 書き込みと同じ動作を行いますが、レーザを発射せず、CDへの書き込みは行われません。 書き込みテストを行うときのみONにしてください。
レーザー出力の最適化を行う | 書き込み前にレーザー出力の最適化を行います。 ONにすると、出来上がったCDの品質を高める事が出来ます。 通常はONにしてください。
バッファ・アンダーラン防止機能を使用する | Burn-Proofなどのバッファ・アンダーラン防止機能を有効にします。 通常はONにしてください。
終了時にディスクを排出する | 書き込みが終了したときに、CDをドライブから排出します。 エラー発生時にも排出するので、気を付けてください。 通常はONにしてください。
ドライブが書き込み対応かどうか調べる | 選択したドライブが書き込み可能なドライブであるかどうかを調べます。 チェックを外してもCD-ROMドライブで書き込みが出来るわけではありません。 通常はONにしてください。
ライティングコマンドの自動検出 | 最適なライティングコマンドを探します。 RAW+96が最優先で、RAW+16、SAOの順で使用します。 RAW+96(Packed)は問題が多いので、今のところ使用しません。 何が選ばれるかは、ドライブの能力を調べれば分かります。
書き込み速度 | ライティングするときの速度を指定します。 ドライブが対応していない速度を指定すると、一番近い速度が適応されます。 ただし、メディアによっては強制的に速度変更される事もあります。

ライティングコマンド

SAO(非RAW) | 標準MMCコマンドを用いてライティングを行います。 現在のバージョンでは、あまり互換性が高くありません。 他のモードが対応している場合は選択しない方がよいでしょう。 マルチセッションのCDは書き込めません。
RAW+16 | 拡張MMCコマンドを用いてライティングを行います。 TOCとサブチャンネルの一部を手動で生成してライティングを行っています。 SAOでは表現できない一部のCDも作成する事が出来ます。 CD-Textは書き込めません。
RAW+96 | 基本的にRAW+16と同様です。 こちらは、TOCと全てのサブチャンネルデータを手動で生成します。 CD Manipulatorの全機能を利用でき、安定度も高いです。
RAW+96(Packed) | 基本的にRAW+96と同様です。 データのフォーマットが違うだけで、機能は同じです。 PX-R820やPX-W1210（プレク全般？）ではコースターが出来るので注意。


 CDのコピー
CDのコピー方法
  1. メニューから「コピー」を選んでください。
  2. 読み込みの設定を行ってください。詳しくはイメージ作成を参照してください。
  3. OKボタンを押してください。読み込みが開始されます。
  4. 読み込みが終わったら、書き込みの設定を行ってください。詳しくはイメージの書き込みを参照してください。
  5. OKボタンを押してください。書き込みが開始されます。

注意事項
コピープロテクト付きCDのコピーは、環境さえ整えばある程度可能ですが、 そのやり方などの質問は一切受け付けません。使い方も含めて完全に自己責任でお願いします。
違法なコピーは行わないでください。子供じゃないんですから、その辺りの事は自分で考えて行動してください。


 マスタリング
データCDのマスタリング方法
  1. メニューから「マスタリング」を選んで下さい。
  2. 「データトラックの構造」タブを選択してください。（標準で選択されているはずです）
  3. 登録したいファイルとフォルダをD&Dしてください。
  4. 登録を削除するときは、ファイル（フォルダ）を選択してＤＥＬキーを押してください。
  5. イメージの作成を行う場合は、メニューから「イメージ作成」を選択してください。
  6. CDへ書き込む場合は、メニューから「CDへ書き込み」を選択してください。

ISOファイルの書き込み
  1. メニューから「マスタリング」を選んで下さい。
  2. 「トラックリスト」タブを選択してください。
  3. 登録したいISOファイルをD&Dしてください。
  4. メニューから「CDへ書き込み」を選択してください。

音楽CDのマスタリング
  1. メニューから「マスタリング」を選んで下さい。
  2. 「トラックリスト」タブを選択してください。
  3. 登録したいWAVファイルをD&Dしてください。1ファイル1トラックとして登録されます。
  4. イメージの作成を行う場合は、メニューから「イメージ作成」を選択してください。
  5. CDへ書き込む場合は、メニューから「CDへ書き込み」を選択してください。

MixモードCDのマスタリング
「データCDのマスタリング」と「音楽CDのマスタリング」、又は「ISOファイルの書き込み」と「音楽CDのマスタリング」を組み合わせることにより、 MixモードのCDを作成できます。

但し、CD-Extra(音楽トラックの後にデータトラックを入れる方式）は作成できません。

設定

常にWindowを最上位 | このオプションをONにすると、マスタリングのウィンドウが後ろへ隠れなくなります。
ファイル名を切りつめたら通知する | このオプションをONにすると、長いファイル名を切りつめた場合に、警告が表示されます。
コピープロテクト | コピープロテクトの設定が行えます。(RAWモード専用) 特殊セクタの時間が長いほど強固になりますが、その分容量を消費します。 ISOファイルの書き込み時や、音楽トラックのみの時にはプロテクトは掛かりません。


 各種設定
命令の送信にSPTIを用いる
※Windows 2000/XP専用

このスイッチをONにすると、ASPIの代わりにSPTIを用いてドライブを制御します。 SPTIを使わず、ASPIマネージャを使用する場合はOFFにしてください。
SPTIを使うと、ASPIマネージャのインストールが不要になり、さらにUSBやIEEE1394のドライブが使用できるようになります。

ASPIマネージャを指定する
このスイッチをONにすると、ASPIマネージャを明示的に指定することが出来ます。
OFFにすると、Windowsへインストールされている標準ASPIマネージャを使用します。

ログを自動的に保存する
このスイッチをONにすると、一定の作業ごとにログを自動保存します。

外部のスキンを使用する
このスイッチをONにすると、スキンとしてBMPファイルを使用します。
このBMPファイルのフォーマットは404x90の未圧縮BMPで、色数は何色でも良いです。

CD複製用の一時ファイル
ここへは、コピーに使う一時ファイルを指定します。
コピーの時にファイル名を指定すると、そのファイル名が自動的に一時ファイルとして記憶されます。

サブチャンネルの解析法

２倍追跡 | 一番高速にサブチャンネルを解析する方法。
等倍追跡 | あまり早くないが、ディスクの状態が悪い場合にオススメ。
全セクタサーチ | 等倍追跡でも出来ないようなディスクで使用してください。

送信ブロックサイズ
CD書き込み時に、一度に送るデータ量を指定します。
この値が大きいほど安定しますが、「リードイン書き込み中にエラー」が出ることがあります。
エラーが発生する場合は送信ブロックサイズを小さくしてみて下さい。

プロセスの優先度
CDの読み書きスレッドの優先度を設定できます。
書き込み時にバッファ・アンダーランが発生するようでしたら、「優先的に実行」を選んでみてください。


 トラブルシューティング
ドライブが認識されない | ドライブが認識されない場合はこちらへ
書き込みが出来ない | 書き込み中にエラーが出る場合はこちらへ
よくある質問 | その他、よくある質問はこちらへ


 ドライブが認識されない
マイコンピュータ上にドライブが表示されない
Windowsがドライブを認識していないと、CD Manipulatorで使うことが出来ません。
何とか頑張って、マイコンピュータ上に表示されるようにしましょう。

外付けドライブが認識されない
Windows 98/Meでは、USBやIEEE1394で接続されたドライブは使用できません。

Windows 2000/XPで外付けドライブが認識されない場合は、ASPIを使わずにSPTI経由で使用してください。

Administrator権限を持っていない
Windows 2000/XPでは、Administrator権限を持っていないとSPTIが使えません。

もし、権限を持っていない場合はAdaptec社のASPIマネージャをインストールし、 SPTIの代わりにASPIを利用すればCD Manipulatorを使用できます。 (設定の変更は、こちらを参照)
ただし、ASPI 4.70以降はレジストリの書き忘れがあり、うまく認識されない場合が有ります。 この場合は、ASPI 4.60をインストールした後に、4.70をインストールしてください。


 書き込みができない
「リードイン書き込み中にエラー（このドライブには対応していません）」と出る
「プリギャップ書き込み中にエラー発生」と出る
原因としては、いくつか考えられます。

1.ドライブが受け取れない大きさのデータを送っている。
各種設定で送信ブロックサイズを小さくしてみて下さい。 一番小さくしても動作しないようでしたら、他に原因があると思われます。

2.変換アダプタとの相性が悪い
ATAPIのドライブをUSBやIEEE1394などに変換して使用している場合、 変換アダプタが邪魔をする事があります。 中身を取り出し、ATAPIドライブとして接続すれば、使えると思われます。

3.IDEコントローラ、ドライブとの相性が悪い
多くの場合は、これが原因だと考えられます。 CD Manipulator、IDEコントローラ、ドライブの間の相性によっては、動作しないことがあります。
この場合は諦めていただくしかありません。 (報告をしていただいても、対応できる可能性はほとんどありません)

ある程度書き込みを行った後、エラーが発生する
ドライブへの転送速度が遅いと、エラーが発生して終了することがあります。 これを、バッファ・アンダーランと呼びます。

ただし、最近のドライブ（１２倍速以降のドライブのほとんど）は、 このようなエラーを防ぐ機能を持っており、 「バッファ・アンダーラン防止機能を使用する」オプションをONにしておけばエラーを防ぐことが出来ます。
昔のドライブには、このような機能はありません。その場合は、プロセスの優先度を「優先的に実行」に変えてみてください。

「Cue-Sheetエラー:解析不能の命令です：…」と出る
CD Manipulator以外のソフトで作成したCue-Sheetを書き込もうとすると、 このようなエラーが出ることがあります。 CD Manipulatorでイメージを作り直してください。


 よくある質問
言語ファイルが読み込めません
「Can't read language file File:…」とメッセージが出てきます
WinFD等のファイラーを使っていると、設定ファイルや言語ファイルの読み書きがうまく行えないことがあります。
エクスプローラから実行するか、デスクトップへショートカットを作成してそこから実行しましょう。

プリギャップ読み込み性能は、どうやって計測するの？
マルチセッションモードとプリギャップ解析のオプションをONにしてCDを読み込んでみてください。 このとき、テストモードであっても構いません。
プリギャップの読み込みが終わると、その結果がログへ記入されます。

プロテクト付きCDがコピーできません
プロテクト付きCDのコピーは、環境ややり方によって出来る事と出来ない事があります。
プロテクト付きCDのコピーは使い方も含めて、完全に自己責任でお願いします。

ソースコードは入手できませんか？
現在、ソースコードの一般公開は行っておりません。
しかし、ＣＤ関係のフリーソフトを作成されておられる方や、 これから作成しようかと思われる方には、個人的に送付しようかと思います。
ただし、誰にでもという訳にはいかないので、ご了承お願いします。 （簡単ですが、アンケートに答えていただいた方にのみ、お渡しします）